summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Silas Bartha <[email protected]>2024-05-27 14:20:08 -0400
committerLibravatar Silas Bartha <[email protected]>2024-05-27 14:20:08 -0400
commitccb19be9d0e918070029f31a86c7eb546121bd87 (patch)
tree6192bc514a7ae815a8863a23b4cc59405c18ec37 /Cargo.toml
parentd088553bd19c58543b908936ba8bae2bfa877b50 (diff)
Updated docs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 11 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9a471d6..10ab85a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,13 +4,17 @@ version = "0.1.0"
edition = "2021"
[features]
-default = ["jpg", "png", "lossless"]
-jpg = []
-png = []
-lossless = []
+default = ["jpeg", "lossless"]
+jpeg = ["dep:img-parts"]
+lossless = ["dep:image"]
[dependencies]
-colored = "2.1.0"
-image = "0.24"
-img-parts = "0.3.0"
thiserror = "1.0.61"
+
+[dependencies.img-parts]
+version = "0.3.0"
+optional = true
+
+[dependencies.image]
+version = "0.24"
+optional = true