aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Silas Bartha <[email protected]>2024-09-09 18:44:52 -0400
committerLibravatar Silas Bartha <[email protected]>2024-09-09 18:44:52 -0400
commit1e80d0684ddbcd3d995a05e572fafb181263758c (patch)
treec0b6b9366a00fe5148a691faac7e0cc8569e98a7 /Cargo.toml
Initial Commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1a83875
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "bevy_rustysynth"
+description = "A plugin which adds MIDI file and soundfont audio support to the bevy engine via rustysynth."
+version = "0.1.0"
+edition = "2021"
+license = "0BSD OR MIT OR Apache-2.0"
+
+[dependencies]
+rustysynth = "1.3"
+itertools = "0.13"
+async-channel = "2.3"
+rodio = "0.19"
+
+[dependencies.bevy]
+version = "0.14"
+default-features = false
+features = ["bevy_audio", "bevy_asset"]