aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Silas Bartha <silas@exvacuum.dev>2024-12-20 08:02:55 -0500
committerLibravatar Silas Bartha <silas@exvacuum.dev>2024-12-20 08:02:55 -0500
commit652a17e0f90a045b99a80044be313e23b9529005 (patch)
tree0fec702d8a143cc67c1845eb4214aba5ee0d1d7d /Cargo.toml
parent87172fd904a9d461b10438be7dc55660e7ced680 (diff)
parent39e8be3872232d929c4ccaa1b595bf61d656b2fe (diff)
Merge branch 'wip'
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a001ad0..9651025 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "bevy_terminal_display"
-version = "0.5.0"
+version = "0.5.1"
edition = "2021"
license = "0BSD OR MIT OR Apache-2.0"
description = "A plugin for the Bevy game engine which enables rendering to a terminal using unicode braille characters."
@@ -8,15 +8,21 @@ repository = "https://git.exvacuum.dev/bevy_terminal_display"
[dependencies]
crossbeam-channel = "0.5"
-crossterm = "0.28"
downcast-rs = "1.2"
once_cell = "1.19"
bevy_headless_render = "0.2"
bevy_dither_post_process = "0.3"
ratatui = "0.29"
color-eyre = "0.6"
+leafwing-input-manager = "0.15"
+serde = "1.0"
+smol_str = "0.2"
[dependencies.bevy]
version = "0.15"
default-features = false
features = ["bevy_render"]
+
+[dependencies.crossterm]
+version = "0.28"
+features = ["serde"]